summaryrefslogtreecommitdiff
path: root/patat.cabal
blob: ccb8d09bf65891d3feb5a1678f663ac7e68ebcae (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
Name:                patat
Version:             0.8.2.2
Synopsis:            Terminal-based presentations using Pandoc
Description:         Terminal-based presentations using Pandoc.
License:             GPL-2
License-file:        LICENSE
Author:              Jasper Van der Jeugt <m@jaspervdj.be>
Maintainer:          Jasper Van der Jeugt <m@jaspervdj.be>
Homepage:            http://github.com/jaspervdj/patat
Copyright:           2016 Jasper Van der Jeugt
Category:            Text
Build-type:          Simple
Cabal-version:       >=1.10

Extra-source-files:
  CHANGELOG.md
  README.md

Source-repository head
  Type:     git
  Location: git://github.com/jaspervdj/patat.git

Flag patat-make-man
  Description: Build the executable to generate the man page
  Default:     False
  Manual:      True

Executable patat
  Main-is:           Main.hs
  Ghc-options:       -Wall -threaded -rtsopts "-with-rtsopts=-N"
  Hs-source-dirs:    src
  Default-language:  Haskell2010

  Build-depends:
    aeson                >= 0.9   && < 1.5,
    ansi-terminal        >= 0.6   && < 0.10,
    ansi-wl-pprint       >= 0.6   && < 0.7,
    base                 >= 4.8   && < 5,
    base64-bytestring    >= 1.0   && < 1.1,
    bytestring           >= 0.10  && < 0.11,
    colour               >= 2.3   && < 2.4,
    containers           >= 0.5   && < 0.7,
    directory            >= 1.2   && < 1.4,
    filepath             >= 1.4   && < 1.5,
    mtl                  >= 2.2   && < 2.3,
    optparse-applicative >= 0.12  && < 0.15,
    pandoc               >= 2.0.4 && < 2.7,
    process              >= 1.6   && < 1.7,
    skylighting          >= 0.1   && < 0.8,
    terminal-size        >= 0.3   && < 0.4,
    text                 >= 1.2   && < 1.3,
    time                 >= 1.4   && < 1.10,
    unordered-containers >= 0.2   && < 0.3,
    yaml                 >= 0.8   && < 0.12,
    -- We don't even depend on these packages but they can break cabal install
    -- because of the conflicting 'Network.URI' module.
    network-uri >= 2.6,
    network     >= 2.6

  If impl(ghc < 8.0)
    Build-depends:
      semigroups >= 0.16 && < 0.19

  Other-modules:
    Data.Aeson.Extended
    Data.Aeson.TH.Extended
    Data.Data.Extended
    Patat.AutoAdvance
    Patat.Images
    Patat.Images.Internal
    Patat.Images.W3m
    Patat.Images.ITerm2
    Patat.Presentation
    Patat.Presentation.Display
    Patat.Presentation.Display.CodeBlock
    Patat.Presentation.Display.Table
    Patat.Presentation.Fragment
    Patat.Presentation.Interactive
    Patat.Presentation.Internal
    Patat.Presentation.Read
    Patat.PrettyPrint
    Patat.Theme
    Paths_patat
    Text.Pandoc.Extended

Executable patat-make-man
  Main-is:          make-man.hs
  Ghc-options:      -Wall
  Hs-source-dirs:   extra
  Default-language: Haskell2010

  If flag(patat-make-man)
    Buildable: True
  Else
    Buildable: False

  Build-depends:
    base   >= 4.8  && < 5,
    mtl    >= 2.2  && < 2.3,
    pandoc >= 2.0  && < 2.7,
    text   >= 1.2  && < 1.3,
    time   >= 1.6  && < 1.10