summaryrefslogtreecommitdiff
path: root/INSTALL.md
diff options
context:
space:
mode:
authorPhilFreeman <>2016-03-26 20:48:00 (GMT)
committerhdiff <hdiff@hdiff.luite.com>2016-03-26 20:48:00 (GMT)
commit6bc83edfdc50ee74921ae3e0e751a764c8a618fa (patch)
treec7b64824ccb2279ce03f4b751e2e3656fa1a1937 /INSTALL.md
parent0bdc658bac6649643d96d50c5803c123273de9af (diff)
version 0.8.3.00.8.3.0
Diffstat (limited to 'INSTALL.md')
-rw-r--r--INSTALL.md12
1 files changed, 4 insertions, 8 deletions
diff --git a/INSTALL.md b/INSTALL.md
index c58652f..4414a13 100644
--- a/INSTALL.md
+++ b/INSTALL.md
@@ -6,8 +6,8 @@ alternatively Stack Overflow.
## Using prebuilt binaries
-The prebuilt binaries are compiled with GHC 7.8.4, and therefore they should
-run on any operating system supported by GHC 7.8.4, such as:
+The prebuilt binaries are compiled with GHC 7.10.3, and therefore they should
+run on any operating system supported by GHC 7.10.3, such as:
* Windows 2000 or later,
* OS X 10.7 or later,
@@ -23,11 +23,11 @@ requirements.
## Compiling from source
-GHC 7.6.1 or newer is required to compile from source. The easiest way is to
+GHC 7.10.1 or newer is required to compile from source. The easiest way is to
use stack:
```
-$ stack install --resolver lts purescript
+$ stack install --resolver=nightly purescript
```
This will then copy the compiler and utilities into `~/.local/bin`.
@@ -39,10 +39,6 @@ If you don't have stack installed yet there are install instructions
If you don't have ghc installed yet, stack will prompt you to run `stack setup`
which will install ghc for you.
-The PureScript compiler has been known to run on OS X 10.6 when built with GHC
-7.6.
-
-
## The "curses" library
`psci` depends on the `curses` library (via the Haskell package `terminfo`). If